Jump to content

Skylords Reborn on OSX/Linux via Wine!


Recommended Posts

hey Lordakius, hab gesehen das du deutscher bist. Hb seit 3 tagen ein Mac book pro. könntest du mir mal eben einmal schritt für schritt erklären was ich jz machen muss. ist mir hier zu unübersichtich geworden. Battle Force ist so ein Nostalgie Spiel für mich.
Danke schon mal im voraus.

@Lordakiussaw that you are German. Have a Mac book pro for 3 days. could you just explain to me step by step what i have to do now. has become too confusing for me here. Battle Force is such a nostalgia game for me.

 Thank you in advance.

Link to post
Share on other sites
1 hour ago, Lucas9987 said:

hey Lordakius, hab gesehen das du deutscher bist. Hb seit 3 tagen ein Mac book pro. könntest du mir mal eben einmal schritt für schritt erklären was ich jz machen muss. ist mir hier zu unübersichtich geworden. Battle Force ist so ein Nostalgie Spiel für mich.
Danke schon mal im voraus.

@Lordakius

Please post an English translation

Link to post
Share on other sites
16 hours ago, Lucas9987 said:

hey Lordakius, hab gesehen das du deutscher bist. Hb seit 3 tagen ein Mac book pro. könntest du mir mal eben einmal schritt für schritt erklären was ich jz machen muss. ist mir hier zu unübersichtich geworden. Battle Force ist so ein Nostalgie Spiel für mich.
Danke schon mal im voraus.

@Lordakiussaw that you are German. Have a Mac book pro for 3 days. could you just explain to me step by step what i have to do now. has become too confusing for me here. Battle Force is such a nostalgia game for me.

 Thank you in advance.

I am not using mac, so no idea what exactly has to be done. Either use lutris (tho no idea if lutris is available under mac -- worst case you could build it yourself i guess) or just follow OPs instructions.

 

3 hours ago, Breimatscher said:

Is there a way to make the change of config.json permanent? After each launch i have to delete the max shader line again.

If you are using lutris you can add a prelaunch script, that does this change (or you can write a custom start script if you are not using lutris)

 

 

Link to post
Share on other sites
  • 2 weeks later...
On 1/30/2021 at 1:12 PM, Lordakius said:

If you are using lutris you can add a prelaunch script, that does this change

And how do I do this?

Edit: I found a walkaround myself.

Just make the config.json a "just readable" file in the options. (I mean  after you deleted maxshader of course)

Edited by HerrDesHimmels
Link to post
Share on other sites
  • 1 month later...

For anyone with macOS 10.15 Catalina, Wine will not work out of the box as described here: https://wiki.winehq.org/MacOS

But, as the user Leszek Szary wrote in the following link, he managed to run Wine 64 bit and posted a how to: https://apple.stackexchange.com/questions/373851/how-to-get-wine-working-on-catalina

Additionally he wrote in the Edit section of his comment the alternative of PlayOnMac: https://www.playonmac.com/en/

 

I for myself actually run Skylords Reborn in a VMware Fusion Virtual Machine. The game runs fine, but I will try PlayOnMac someday for sure.

Link to post
Share on other sites
  • 1 month later...
Posted (edited)

Since the latest update from 23.May 2021 I can no longer login to the game, it just says "Connection failed".

In Documents/BattleForge/Diag/_log_proxy_x.log there is a new error message "launcher connecting error 1: Failed to open \Device\Afd\Mio: File not Found. (os error 2)" which was not present before. Maybe this is related to https://bugs.winehq.org/show_bug.cgi?id=50520 ?

Edited by mx2
Link to post
Share on other sites
5 hours ago, mx2 said:

Since the latest update from 23.May 2021 I can no longer login to the game, it just says "Connection failed".

In Documents/BattleForge/Diag/_log_proxy_x.log there is a new error message "launcher connecting error 1: Failed to open \Device\Afd\Mio: File not Found. (os error 2)" which was not present before. Maybe this is related to https://bugs.winehq.org/show_bug.cgi?id=50520 ?

I am getting this too on OSX 

Link to post
Share on other sites
2 hours ago, Lchf said:

I am getting this too on OSX 

 

7 hours ago, mx2 said:

Since the latest update from 23.May 2021 I can no longer login to the game, it just says "Connection failed".

In Documents/BattleForge/Diag/_log_proxy_x.log there is a new error message "launcher connecting error 1: Failed to open \Device\Afd\Mio: File not Found. (os error 2)" which was not present before. Maybe this is related to https://bugs.winehq.org/show_bug.cgi?id=50520 ?

Could you please re-try? We rolled out an update that might have fixed this issue.

Link to post
Share on other sites
  • 5 months later...

Hi all,

I improved the Lutris installer for Skylords Reborn. It should now work much better once the new installer gets accepted (for now you can use the following Lutris link to use this installer: lutris:skylords-reborn?revision=79253). The changes are as follows:

- Don't install d3dx9, d3d9compiler_43 and d3d9compiler_47 alongside d9vk (as stressed by the release notes: https://github.com/Joshua-Ashton/d9vk/releases). Otherwise the game won't render correctly. This especially affects the in-game UI, but in general anything that relies on alpha blending.
- Add the following registry key to the Windows registry: HKEY_CURRENT_USER/Software/Microsoft/Avalon.Graphics/DisableHWAcceleration with type DWORD and value 1. This disables hardware acceleration for WPF and ensures that the updater renders correctly. Before this change the updater would render noise, the original frame before the window was created or show a black window unless you started moving it around, or anything else that causes the graphics to refresh.
- Remove the dependency on lutris-5.7-1-x86_64. It should now default to latest, which is lutris-fshack-6.14-4-x86_64. This ensures winetricks is up-to-date with the latest fixes. One of those fixes is related to the deadlock that would sometimes occur when trying to install dotnet461, which required you to cancel the installation, run it again and pray that it would not run into a deadlock again. That issue is now fixed, which means this should now install and work out of the box.

Edited by Synthrea
Link rendering does not work for Lutris links.
Metagross31 and Aviat0r like this
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use