Wish to contribute to the project by donating? Heads up to our Patreon -> https://www.patreon.com/skylordsreborn

Jump to content
BEWARE: Multiaccounting Will Cause Permabans! Read more... ×
Sign in to follow this  
Archaon

Lost Wanderer not healing at buildings

Recommended Posts

Greetings, fellow beta testers and the Skylords Reborn team! I came across a few issues when using the 'Lost Wanderer' unit, so I decided to submit a bug report concerning them.

 

NAME: Lost Wanderer Unit / Ownership Classification Bug
SEVERITY: 3
LOCATION: Lost Wanderer unit (in-game)
PREVALENCE: Constant

DESCRIPTION: A Lost Wanderer entity, summoned by a player, does not seem to count as a friendly ground unit – even if it is your own Lost Wanderer. You can control the unit without any issues, but having it next to a treasure chest will make the chest irretrievable, as if an enemy unit was standing next to it. You can pick up treasure chests once any Lost Wanderers are out of range. Furthermore, Lost Wanderers do not receive healing when standing next to owned or allied Power Wells and Monuments.

ADDITIONAL INFORMATION: Unrelated to the unit / ownership classification issue, but Lost Wanderers also seem to have very poor and possibly bugged unit / order / pathing AI. Lost Wanderers tend to remain idle when given attack-move orders when friendly units are nearby. It seems as if they want to hang back a bit and apply barriers to friendly units, but they often remain idle even after friendly units move out of range, almost as if they dropped any move or attack move orders.

Edited by Archaon
Additional information added
Loriens likes this

Share this post


Link to post
Share on other sites

NAME: Lost Wanderer not healing at buildings

DESCRIPTION: Sometimes Lost Wanderer does not want to heal when close to a building.

REPRODUCIBILITY: In the forge cast a building and then surround it with Lost Wanderers. I wait a little bit before casting each one, to space them apart, then let them shield each other up. Then switch to the opponent mode and cast Lava Field. Wait and see that the units don't heal correctly. I tested with other units and they start healing correctly, but Lost Wanderer doesn't. Sometimes they get little bursts of healing but then it stops again. (Maybe only a problem when there are more than one (the more the worst) Lost Wanderer in play?)

SCREENSHOT/VIDEO: Tried to upload a screenshot, but can't. I get an "-200" error when I try to upload.

LOG: Didn't save the logs and can't attach files (see above).

ADDITIONAL INFORMATION: I suspect it has something to do with them casting shields all the time, maybe they don't get "out of combat" to start healing? Pressing the Stop command doesn't help, but I did manage to get a Lost Wanderer to regenerate a little HP (before it stopped regenerating again) by moving it around the powerwell, maybe entering and leaving the area close to the well in the process.

Edited by Kooning

Share this post


Link to post
Share on other sites

Yes, I noticed it in normal games first, then tried to recreate in the forge.

This also seems to happen to the fire shamans (Warlock?). They also cast buffs and thus seem to stay in combat and not heal properly.

Share this post


Link to post
Share on other sites

Thats not a bug imho. The healing begins when the unit is no longer "busy". as long as they keep themselves busy by shielding units, they don't heal.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.