Jump to content

Batariel (P) aura sadness


Recommended Posts

NAME: Batariel (P) broken (not the OP kind, the pathetic kind)
SEVERITY: 2 .5-ish
LOCATION: Forge, probably in any match
REPRODUCIBILITY: ALWAYS
DESCRIPTION: Batariel (P)'s aura doesn't seem to work right. His aura has difficulty activating and doesn't ramp up. Instead it just dies out. This occurs when attacking a somewhat smaller number of targets (one XL target (Spore Launcher) or three M targets (Grove Spirits)). Batariel (R) has no such problem. Against small units (e.g. Skeleton Warriors) both do fine, but since they insta-kill the rest of the units upon aura activation, I can't observe any advantage purple should have (what is "burn away enemies' armor" supposed to mean?).

EDIT: Okay, I now noticed (while hitting walls) that Batariel (P) also gives a +35% ... +75% damage taken debuff.

SCREENSHOT:Batariel(P).thumb.png.dae3ed885516f23ca03fa73a9ab74ea6.png
ADDITIONAL INFORMATION: I don't have the upgrades and I don't want to spend the time farming gold to upgrade him. Maybe with the 940 additional Damage at III he would do fine? It could be that he simply doesn't manage to do the required 1250 damage in 4 seconds, although I thought any melee damage would be enough once the aura is active.

Edited by Sephok
Link to post
Share on other sites
  • 1 year later...

Confirmed this as partially Resolved on the test server.
Question is how exactly its behavior should work. Currently both debuff auras [+35%] and [+75%] seem to work, but here's how it seems to behave in synthetic Forge tests:
First [+35%] aura activates, then stays up for a relatively short time, like 3-4 seconds. Does not get changed to [+75%], though only really seldom changes from [+35%] to [+75%] immediately after (i can be just blind). 
Second [+75%] aura activates only after about 2 seconds as First one depletted, BUT [+35%] reapplies too at the same time, so now the enemy units in the area are under both auras [+35%] and [+75%]. While so, [+35%] aura deplets yet again quite fast, but the [+75%] stays for way longer compared to [+35%]. Then the [+75%] deplets and either sometimes gets reapplied again after about a second or the cycle restarts from the [+35%].

That being said under both debuff auras [+35%] and [+75%] units get damaged twice, which resolves in a huge short time burst, which actually sometimes outperforms the Batariel (:fireorb:), but mainly against XL units. Against regular (and irregular too) camp formations they perform basically on par. The difference is no more than a couple of seconds, which could be caused by randomness of behaviour on battlefield.

Ideally [+35%] should get applied, then changed to [+75%] without overlapping each other and without gaps between the stages, when there is no Aura at all. Also [+35%] shouldn't get reapplied WITH [+75%], when the cycle repeats after [+75%] falls off.

Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use