Wish to contribute to the project by donating? Heads up to our Patreon -> https://www.patreon.com/skylordsreborn

Jump to content
BEWARE: Multiaccounting Will Cause Permabans! Read more... ×
Sign in to follow this  
sidvicious64

I cant use any cards (cards bugged)

Recommended Posts

I have no idea what this bug is but I can't summon any of my cards. I can select the card and hover them on the field but I can't summon them at all. 

Edit: tested running the tutorial and I cant get passed the second step which is to click on open terrain to deselect the unit. For some reason, my left mouse click doesnt register. But strangely my left mouse click does register since I can select any cards I want

 

Edited by sidvicious64

Share this post


Link to post
Share on other sites

In my case playing cards did work, but: the game is running that slow that you'll need to wait about one minute before you are able to cast your first spell, because it takes this long for the first monument to be ready to be used. And even then it takes over 2 minutes for the creatures summoned to show up un the map.

Share this post


Link to post
Share on other sites

I think it has to do with my mouse. I play on the laptop. I connect my Razer death adder. I logged on recently I was able to use it with my mousepad but as soon as I plugged my mouse it stopped working. Not sure if for some reason the game blocks my razer mouse. 

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.