Jump to content

TNF: ErrorInitializingDirectXFallback????

Recommended Posts

I am trying to run the game however I keep getting this error message "TNF: ErrorInitializingDirectXFallback"  when I run the updater file. The steps I took to download and execute goes as follows below:

1. Downloaded both installer and zip file from mediafire. 

2. Dragged both of the files into my C: drive then into game folder then into battleforge folder as shown below.


3. After that I ran the Installer file and got the skylords reborn folder which is what you see above

4. Then I went inside the skylords reborn folder and ran the updater file as shown below.


5. After running the updater file 110/110 loads up and the PLAY button highlights green. After pressing the buttom shortly after the error message box pops up and wont go away

unless I go into the task manager and stop the battleforge program.


I am not sure what the problem is so if anyone knows please help. Thanks in advance!

Edited by SkiiLLzZz__
Link to post
Share on other sites
2 hours ago, Ultrakool said:

    I have tried those steps and still getting that error message that I posted above. I went into the log files through the documents/battleforge path and seen the error message below for each attempt to play. That is my latest attempt. I am not sure what the problem could be. I have an intel video card and tried step 6.

23:02:37.748 WARN 10176 proxy:78 
proxy from 2021-01-19T00:46:39.609618300Z is initializing 
    23:02:37.754 INFO 10176 proxy::networking::connect:181 
connect disconnect hooks initialized 
    23:02:37.754 INFO 10176 proxy::networking:69 
networking hooks initialized 
    23:02:37.754 WARN 10176 proxy:102 
Initialized successfully 
    23:02:38.063 INFO 10176 proxy::logging:72 
src="Direct3D 9" message="Start Scan" 
    23:02:38.063 INFO 10176 proxy::logging:72 
src="DISPLAY" message="GFX API CRASH: Falling back to DirectX 9!" 

2 hours ago, Aviat0r said:

I think you missed the most important step 7 here.

The only thing that I do not have specifically is Directx 9 because I have the version Directx 12. I would assume that my version would work.

Link to post
Share on other sites
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use