Jump to content

launcher.exe has stopped working (bad allocation)

Recommended Posts

So on the Windows 7 VM on my mac, which I use to play this game on the go, I recently started getting the error from the title (launcher.exe has stopped working). What happens then is that the game won't close, but it will tell me I lost connection to the server about 5 seconds later.


It used to work fine before, I got this error a few times but restarting usually made it go away. Not this time, I've gotten the error about 10 times in a row now which is unusual. I will start up, log in and after about 2-3 minutes it will generate this failure. The Diags show only a single error amidst a whole bunch of info messages about packages:


[08:59:29.637400] [error]: [] bad allocation


I don't know where this comes from. Things I've tried:

- Running in administrator mode. I've always done this

- running in compatibility mode. Windows suggests XP service pack 2, I've tried all the service packs.

- Disabling DEP. I coudn't create an exception for the launcher.exe, but disabling it entirely also didn't seem to work

- completely reinstall battleforge and the launcher (a.k.a. unpacking it again and running the launcher).

- restart the VM


I'm hoping you guys have seen this before and can point me in the right direction. 

Link to post
Share on other sites
3 minutes ago, Kubik said:

do you know after which update it started?

I've only experienced 1 update, the most recent one. The launcher issue was present before the update as well, but like I said, before it would just go away after a restart or 2. 

This is quite a fringe case, as it only seems to happen on my VM. My home PC is fine, weirdly enough.

Link to post
Share on other sites
  • Kiwi locked this topic
This topic is now closed to further replies.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use