Jump to content

[E] Exception: Certificate error


Recommended Posts

Greetings,

Trying to start Battleforge I encountered an error claiming libssl-1_1-x64.dll is missing. After acquiring that, I now get a "Launcher Fatal Error" message upon attempting to run the game - though it does launch and take me to the login menu, it fails to connect there.

The log reads as follows:

[15:04:41] main(): Initializing Launcher
[15:04:41] main(): Game started
[15:04:41] main(): Game ready
[15:04:41] main(): [E] Exception: Certificate error
[15:04:41] main(): [E] Exception: Certificate error
[15:04:41] main(): [E] Exception: Certificate error
[15:04:41] main(): [E] Exception: Certificate error
[15:04:41] main(): [E] Exception: Certificate error
[15:04:41] main(): [E] Exception: Certificate error
[15:04:41] main(): [E] Exception: Certificate error
[15:04:41] main(): [E] Exception: Certificate error
[15:04:41] main(): [E] Exception: Certificate error
[15:04:41] main(): [E] Exception: Certificate error
[15:04:42] Exiting: END

I'll be grateful for any help you can provide.
-Mr. T

Link to post
Share on other sites

You need to fix the root cause of the problem. The Updater is getting blocked by Windows. Smart Screen, Defender or Windows Store settings. Normally those files are getting downloaded by the Updater. But they can't be updated if the Updater is getting blocked from downloading/accessing files.

Dyornos likes this
Link to post
Share on other sites
23 minutes ago, Kubik said:

I think you recently update windows, doesn't you?
Microsoft can not make it harder for us :unsure:

No, I haven't. I'm using Windows 7. There is no windows store or smart screen, and I am running the launcher as admin.

 

The folder (and launcher specifically) are whitelisted on both the firewall and anti-virus I use. Still, the problem persists.

 

Something I've noticed: running the launcher always makes it patch one file. I don't know what it is, or why, but I just noticed that.

 

I've you've any other suggestions, please do tell.

Edited by Mr_Turtle
Link to post
Share on other sites
2 minutes ago, Mr_Turtle said:

I downloaded the two dlls linked; the game no longer gives me a Fatal Launcher Error, and the log no longer contains anything in it.

 

However, I still get "Connection Failed!" when attempting to login.

I would suggest following this topic :) 

 

 

 

Link to post
Share on other sites
8 hours ago, Aviat0r said:

You need to fix the root cause of the problem. The Updater is getting blocked by Windows. Smart Screen, Defender or Windows Store settings. Normally those files are getting downloaded by the Updater. But they can't be updated if the Updater is getting blocked from downloading/accessing files.

I added the SkylordsRebornUpdater to the list of exceptions in the Defender/Firewall menu, however the launcher still does the single update and the two .dll files are reported to be missing.

 

Thanks to the devs looking into this!

Link to post
Share on other sites
  • 4 weeks later...
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use