Jump to content

Tutorial for working with Battleforge 3D models in Blender

Recommended Posts

Things you will need to download:
FBX Converter - https://www.autodesk.com/developer-network/platform-technologies/fbx-converter-archives
BF Model Viewer - https://drive.google.com/file/d/1O0SdQE3Jo0HECUZjbLhbdauZhHoLibAU/view
Blender - https://www.blender.org/download/ 

To start off, make sure you exported all the models from BF into the BFModels folder in BFModelViewer folder. Open BFModelViewer.exe, choose your graphics options, and hit Play!. Navigate to your choice of model .drs, as an example I'll take skel_human_claw > unit_striker.drs and hit Export to FBX. Next go to that folder \BFModels\skel_human_claw\unit_striker.fbx, open FBX Converter, and drag and drop your unit_striker.fbx.fbx file into the left side of FBX Converter. On the right, change FBX Save Mode to Binary and hit Convert. Back in the folder, you'll now see it made another folder called FBX 2013 and in there is the .fbx file you'll need to import into Blender. So Open Blender, File > Import > Import FBX, navigate to that FBX 2013 folder, and import it (no need to change options).

To get textures working, go to the Shading tab and you'll have to go back to the \skel_human_claw\ folder and create a new texture, add a image texture, or drag and drop the .dds files (ex. unit_striker_col.dds) from the folder directly. Next, create a Mapping and Texture Coordinate node (CTRL+T if you have Node Wrangler enabled) and connect them together. Connect the unit_striker_col.dds to the Color node on the Principled BSDF. You'll notice the textures are not right, so you need to change the Y Scale on the Mapping node to -1.000 instead of 1.000, then you should see it looks correct. You will also need to connect the _par and _nor files to their respective places as I have shown in the attached image (Separate Color = Separate RGB depending on Blender version). And now you should have a fully textured Battleforge model in Blender.

If you want to change the textures, you'll need to flip the UVs manually instead of using Y Scale: -1.000 on the Mapping node. To do that, go to UV editing tab, select all (A), and invert them on the Y axis (you can just type S, Y, -1) to show them correctly.


Zyna and Metagross31 like this
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use