Jump to content

EarthRed

Member
  • Content Count

    10
  • Joined

  • Last visited

About EarthRed

  • Rank
    Fighter

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Found a bug: if I hide t4 cards, click "Only Show Playable Cards" and then tick my orbs to be nature nature fire, I can't see any twilight units or twilight tier 2 cards. I can only see them if I enable t4 cards, but then I see a lot of of cards that don't fit my orbs of choice (such as Deepfang and Harvester), plus them and all twilight cards are not sorted properly. Screenshot:
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use