Jump to content

Suddenly game wont start.


Recommended Posts

I have been a little distracted by another game I won't mention, recently, but previous to that I had been on SkylordsReborn daily.  While I was distracted, I noticed 2 different updates occurred which seem to have caused the issue of my game not appearing after START is clicked on teh launcher.  I disabled my system security and it still does not start.  I am uncertain how to potentially resolve the issue.  Should I try reinstalling?


Thanks in advance for any info.

Link to comment
Share on other sites

Thanks for the reply.  I noticed my PC was doing strange things after I encountered the issue of Skylords Reborn not opening past the launcher, running slowly, and things would not open completely or would be sluggish.  No idea why or how it happened.  For reference, I have a gen 4.0 rocket m.2, a 5800x, r9 390, and 16gb 4000mhz RAM.  After my PC had fully rebooted more than once, I tried running the game 10 mins ago from the time of this post and it opened fine.  I also noticed yet another update, no clue if that fixed it or if the problem was something else.

Edited by Owedevil
Link to comment
Share on other sites

  • 2 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use