Jump to content

Updater stuck on checking?


Recommended Posts

First thing I'll say is hello, I'm new here.

 

As for my problem, after I finished installing the game, I ran the updater and it performed a big check of updates, installed about 220ish of them, then the updater restarted itself. Now, it just stays at the checking part, never seeming to find anything for hours. It says it's PATCHER v0.11. I'm currently running it on Windows 7. There didn't seem to be any issues installing from what I saw. Have tried running the updater as an administrator and deleted the Battleforge document folder, for what its worth.

 

Thank you for your time.

 

EDIT: waited 5 hours to see if any progress would be done, and none was, so have now also tried a fresh installation, making sure my antivirus was off during it. It now doesn't seem to even get the first 220ish updates it downloaded the first time, staying at PATCHER v0.4.

Edited by Omnilisk924
adding new details from own attempts to fix.
Link to post
Share on other sites

It should always update itself to the newest version - in this case v0.11. Windows 7 sometimes does weird things which also forced me to implement some "hacky" things to let the newest version run on there.

Did you make sure nothing else is blocking the Updater from downloading files? We also had some problems in the past were a router restart helped in such cases. Also check if there's a SkylordsRebornUpdater.exe.upd file in your directory. If this is the case, try to manually reload it to SkylordsRebornUpdater.exe. Maybe do a backup of your current version before. Maybe it just can't execute the Patcher.exe to update itself.

And the last but probably most important thing is, that you should upgrade to Windows 10 since Windows 7 doesn't get any (security) updates from Microsoft anymore and will get even more problems in the future. We probably also have to drop Windows 7 support at some point to use newer techniques, but I can't tell you when this is happening.

Link to post
Share on other sites
Posted (edited)

I did a search for the SkylordsRebornUpdater.exe.upd file, and nothing came up. Also tried restarting the router, and nothing changed. Also reinstalled again to see if it missed anything last time, but nothing.

 

EDIT: Well, a new update for the better. Just got back on and thought I'd give it another try, and it worked perfectly. Did all the updates without any trouble, and the game started without any issues and I logged in just as fine. Even now, the tried and true "turn it off, then turn it back on" solution works. *sigh*

 

Consider this problem closed, and thank you for your time and consideration in trying to solve it.

Edited by Omnilisk924
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use