Wish to contribute to the project by donating? Heads up to our Patreon -> https://www.patreon.com/skylordsreborn

Jump to content
BEWARE: Multiaccounting Will Cause Permabans! Read more... ×
macabi

Urgent Error - Could not start the launch process, Access Denied

Recommended Posts

When executing the game I am getting the following error:

"Could not start the launch process, Access Denied"

This happens because McAfee Antivirus blocks the Launcher program thinking it's a virus.

This is a new problem as a result of the new update.

Please resolve ASAP or provide a work around with McAfee.

Right now I don't see any options with McAfee to allow the Launch program to run.

 

 

Share this post


Link to post
Share on other sites
Posted (edited)
4 minutes ago, Ladadoos said:

 

Can you please be more specific?

If this bug reporting is lacking some information then please indicate what additional information you need.

I think this is a simple and clear bug that does not require a use of template.

 

Edited by macabi

Share this post


Link to post
Share on other sites
2 minutes ago, Zyna said:

@macabi You have to add an exception for the "Launcher.exe", here's how you can do it for McAffee: https://service.mcafee.com/webcenter/portal/cp/home/articleview?articleId=TS102056

I managed to do that, but McAfee is NOT user friendly and it is hard to figure it out.

You will lose many players because of this issue.

Many players won't be able to figure out how to fix that and they will quit the game.

You must figure out what change is causing this issue and resolve it.

This problem did NOT exist before the recent change.

robynson likes this

Share this post


Link to post
Share on other sites
7 minutes ago, macabi said:

I managed to do that, but McAfee is NOT user friendly and it is hard to figure it out.

If McAfee is not user friendly,  you should consider installing a more user-friendly Anti-Virus software.

 

7 minutes ago, macabi said:

You will lose many players because of this issue.

Many players won't be able to figure out how to fix that and they will quit the game.

You must figure out what change is causing this issue and resolve it.

This problem did NOT exist before the recent change.

I just checked the Launcher.exe on virustotal, and most anti-viruses don't think the new Launcher is a virus. So I wonder how many players are really affected by this. I'm not sure if there's much we can do about anti-viruses falsely detecting our software as a virus.

Share this post


Link to post
Share on other sites
11 minutes ago, Zyna said:

If McAfee is not user friendly,  you should consider installing a more user-friendly Anti-Virus software.

 

I just checked the Launcher.exe on virustotal, and most anti-viruses don't think the new Launcher is a virus. So I wonder how many players are really affected by this. I'm not sure if there's much we can do about anti-viruses falsely detecting our software as a virus.

McAfee is not user friendly when it comes to adding files to the "Exclude List".

Other than that it is very user friendly and very popular. 

Players who use mcAfee will not give it up for Skylords.

There are many free games out there they can play instead.

So, from one Computer Programmer to another, my advice to you is to figure out the new cause for this problem and fix it.....

Share this post


Link to post
Share on other sites
2 minutes ago, Kubik said:

:thinking: why you think all of them are false positives? Some of them are just by definition just description of what the launcher does.

Where did I say that I think all of them are false positives? Can you give me a quote for that? Obviously some Anti-Viruses will recognize the new Launcher as a virus, even though it is not. I assume this is because the new Launcher injects a dll into BattleForge, which does trigger some red flags for some Anti-Viruses.

Share this post


Link to post
Share on other sites
17 minutes ago, Zyna said:

I'm not sure if there's much we can do about anti-viruses falsely detecting our software as a virus. 

sounds to me like you assuming it is a false positive.

Share this post


Link to post
Share on other sites
2 minutes ago, Zyna said:

Where did I say that I think all of them are false positives? Can you give me a quote for that? Obviously some Anti-Viruses will recognize the new Launcher as a virus, even though it is not. I assume this is because the new Launcher injects a dll into BattleForge, which does trigger some red flags for some Anti-Viruses.

It looks like you already have a good idea for what causes this issue.

Surely there is another way for doing what you need the program to do without making McAfee thinking the Launcher is a virus.

Share this post


Link to post
Share on other sites
36 minutes ago, Kubik said:

sounds to me like you assuming it is a false positive.

Your wording was a little bit confusing and I just woke up sorry :P I didn't really consider the results on virustotal which had some generic "Malicious/Unsafe" to be the same as a virus, but I guess they are. I also really don't know what exactly the Real-Time-Protection of an Anti-Virus will classify the Launcher as, so I would argue there will probably be at least some false positives.

Share this post


Link to post
Share on other sites

last time I check most of them was not false positives, only few, and another few have so generic description without any way to get more details that it was not possible to say if they are false or not.

But also these not false positives describe the base operations like reading writing foreign memory, which can be used to make game work, or to stole passwords, and I am not avare of any way AV could go far enough to say if you making the game work, or searching for password.

Share this post


Link to post
Share on other sites
13 hours ago, macabi said:

Can you please be more specific?

If this bug reporting is lacking some information then please indicate what additional information you need.

I think this is a simple and clear bug that does not require a use of template.

We have always asked to follow this template, no matter how simple the issues seems. We spend hundreds of hours of our time to make this game work for you and all we ask of you is to take a few extra minutes to write a proper bug report (following the template).

Share this post


Link to post
Share on other sites

If you dont mind im gonna sneak my little comment about this problem with MCafee antivirus. So i was having the same issues as everyone else, which includes the program detecting some stuff about the launcher then evolving into a QoQ "your system doesn't have the parts that are needed to launch the game". That kinda got me worried that i just camed back to the game to see that it wont work. Anyways back to the topic, becouse no matter how abscure the problem sounds if its the same as for me, for us, for you, just follow what the Dev told you to do. Go to your antivirus, exclude the Launcher.exe and you should be fine. Hope this helps or incourage some people to do it :D

Zyna likes this

Share this post


Link to post
Share on other sites
6 hours ago, Eyvan said:

If you dont mind im gonna sneak my little comment about this problem with MCafee antivirus. So i was having the same issues as everyone else, which includes the program detecting some stuff about the launcher then evolving into a QoQ "your system doesn't have the parts that are needed to launch the game". That kinda got me worried that i just camed back to the game to see that it wont work. Anyways back to the topic, becouse no matter how abscure the problem sounds if its the same as for me, for us, for you, just follow what the Dev told you to do. Go to your antivirus, exclude the Launcher.exe and you should be fine. Hope this helps or incourage some people to do it :D

I have exclude the Launcher.exe in McAfee and it is now fine for me. 

However, many players out there may not be able to figure out the problem which will result in them quitting the game.

So I believe the developers need to resolve this problem soon since we don't have enough players to begin with.

Share this post


Link to post
Share on other sites

I Unninstaled my antivirus and now it say  An error occure while initializing your graphics adapter.This might caused by outdater or corrupted drivers or graphics adapter is unable to run DirectX ./n/nBattleforge will not restart in DirectX 9 fallback mode .

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, macabi said:

I have exclude the Launcher.exe in McAfee and it is now fine for me. 

However, many players out there may not be able to figure out the problem which will result in them quitting the game.

So I believe the developers need to resolve this problem soon since we don't have enough players to begin with.

I told you there's nothing we can do. If you are so certain this can be fixed please suggest a possible solution. As far as I'm aware there's no way to fix this, since we use the Launcher to modify BattleForge so it can connect to our servers. This modification makes the anti-viruses treat out Launcher as a virus. The only thing we can do is to make people aware of this, and to help them with adding the correct exceptions.

 

58 minutes ago, robynson said:

I Unninstaled my antivirus and now it say  An error occure while initializing your graphics adapter.This might caused by outdater or corrupted drivers or graphics adapter is unable to run DirectX ./n/nBattleforge will not restart in DirectX 9 fallback mode .

If you also added an exception for BattleForge in the windows defender then you have a different issue. You'll be able to find the solutions for the most common issues here: https://forum.skylords.eu/index.php?/topic/4207-need-help-check-this-thread-first-clientupdater-troubleshooting/
Your particular error indicates that you need to update your graphics drivers, or that you need to install direct x.

Edited by Zyna

Share this post


Link to post
Share on other sites
33 minutes ago, Zyna said:

I told you there's nothing we can do. If you are so certain this can be fixed please suggest a possible solution. As far as I'm aware there's no way to fix this, since we use the Launcher to modify BattleForge so it can connect to our servers. This modification makes the anti-viruses treat out Launcher as a virus. The only thing we can do is to make people aware of this, and to help them with adding the correct exceptions.

 

The Antivirus detection problem started only after this latest patch.

It didn't exist before the latest update.

Therefore, the conclusion is that recent modifications are causing it.

So my question is - is there another to achieve the latest changes without making McAfee think the Launcher program is a virus.

Maybe Kubik can help.

Share this post


Link to post
Share on other sites
1 hour ago, macabi said:

So my question is - is there another to achieve the latest changes without making McAfee think the Launcher program is a virus.

To which the answer is:

1 hour ago, Zyna said:

The only thing we can do is to make people aware of this, and to help them with adding the correct exceptions.

 

1 hour ago, macabi said:

The Antivirus detection problem started only after this latest patch.

There were already issues about anti-virus prior to this update. And no, we don't need Kubiks help. We can manage on our own.

I will also close this thread and move it to resolved as the solution for this bug has been found. If you, even after the answers from Zyna, still want to discuss this matter, feel free to make another thread in General talk.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.