Wish to contribute to the project by donating? Heads up to our Patreon -> https://www.patreon.com/skylordsreborn

Jump to content
BEWARE: Multiaccounting Will Cause Permabans! Read more... ×
chickennoodler

Laptop screen not big enough for smalles game view setting of 1024 by 768.

Recommended Posts

So. . . . is there a resolution below 1024 by 768? There's no settings for a smaller resolution and the screen basically cuts off below my Laptop's screen so I can't see the cards and some parts of the screen are cut off below. And that's after I put a setting so my toolbar disappears and reappears when I hover at the top of the screen so normally the toolbar is in the way.

I don't think most people play like this so this is very strange to me.

 

What do most people do normally?

Share this post


Link to post
Share on other sites

What's the native resolution of your laptop? Is is really that small? Then it's probably pretty old and you can try to do some things manually.

First thing I would try is to start the game in windowed mode. You can find that setting in the game options called Fullscreen. Remove the tick in the checkbox and restart your game.
The next more expert step would be to open a Windows File Explorer window. Go to the "My Documents\BattleForge" directory and open the file called "config.xml" with your preferred text editor like Windows Notepad, Notepad++, VSCode, Sublime Text, ...
Search for the attribute "screenheight" and "screenwidth" and set the values manually. For example 800 for width and 600 for height. Be sure to keep the display ratio (probably 4:3 in your case). But this seems pretty small for me. So playing the game on that small resolution might not be fun at all.

I hope this helps you somehow.

Share this post


Link to post
Share on other sites

My screen says 1366 by 768, so yeah, the game setting of 1024 by 768 is too big. I experimented quite a bit and found out, the problem is actually that The Game Code somehow forces the Window to automatically center itself and go back down when I try to raise it higher into the Task bar and the above the visible screen to stop hiding the bottom of the Game Window. And since the Windowed Game is 768 like my Monitor, when the Game re centers itself, it always does a bad job and shows the top White portion of the Window and cuts off the bottom which has the Deck and Cards bar at the bottom.

 

I eventually tried and succeeded to partially fix this so I could play by setting the Task bar to hide before starting the Skylords client started so the Windowed Game centers itself slightly Higher so I could see the Very top Half of the Cards and actually press the Deck and card buttons instead of playing blind. Not perfect but better than having to go into Fullscreen (which stretches the game) just to modify and change decks.

Share this post


Link to post
Share on other sites
4 hours ago, chickennoodler said:

My screen says 1366 by 768, so yeah, the game setting of 1024 by 768 is too big. I experimented quite a bit and found out, the problem is actually that The Game Code somehow forces the Window to automatically center itself and go back down when I try to raise it higher into the Task bar and the above the visible screen to stop hiding the bottom of the Game Window. And since the Windowed Game is 768 like my Monitor, when the Game re centers itself, it always does a bad job and shows the top White portion of the Window and cuts off the bottom which has the Deck and Cards bar at the bottom.

 

I eventually tried and succeeded to partially fix this so I could play by setting the Task bar to hide before starting the Skylords client started so the Windowed Game centers itself slightly Higher so I could see the Very top Half of the Cards and actually press the Deck and card buttons instead of playing blind. Not perfect but better than having to go into Fullscreen (which stretches the game) just to modify and change decks.

It is not a client sided bug. The re-centering is handled by Windows so that the menu bar of the window is always visible. If you set the height of the game client to the same height as your native Windows resolution, you should try to play in fullscreen as there will be no centering by Windows.

Another thing you could try, is to use a software which "forces" games to be borderless. Go to this page and try it if you want.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.